Announcement

Collapse
No announcement yet.

Maxx TC battery again

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Maxx TC battery again

    Just a quick question about Maxx TC.
    I got a brand new Maxx from a friend as a second unit.
    I changed TC button battery, since it's in the box for few years without touching. But still the TC is not lock on each time I turn it off and on... It always back to 00:00:00
    I have read most of the threads from jwsound, zax forum and Facebook . Tried change rec-run back to free run, trying to kick it running.... It doesn't work. I got this screen when I boot up ...
    Any sigigestions or the battery needs to be replaced in a right position ?
    †*******************"*"********************"" ***
    After tried few times plug in and out of the new battery... It doesn't work still. So I assume it's not battery problem but this unit is brand new. It shouldn't be the TC chip problem tho...

    Post it here and Facebook try any luck

    ​​​​​​Hiro
Working...
X